Sunday, November 20, 2011

Basic IPv4 / IPv6 Routing

 

IPV6

During your career as a Cisco network engineer you will have to deal understanding IPv6 address structure.  So in this lab scenario you will learn to configure IPv4 and IPv6 networks on two routers then using RIP routing protocol you will configure WAN connectivity between. This lab has been created using Cisco’s Packet Tracer but can be just as easily be done with GNS3 or real hardware.

R1

R1(config)#do sh run
Building configuration...

Current configuration : 1025 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R1
!
!
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
ip ssh version 1
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
description ***Link SW1***
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description ***Link to SW2***
no ip address
duplex auto
speed auto
ipv6 address 2001:1:1:1::1/64
!
interface Serial0/0/0
ip address 10.2.2.1 255.255.255.0
ipv6 address 2001:2:2:2::1/64
ipv6 rip CCNA enable
ipv6 ospf cost 781
!
interface Serial0/1/0
no ip address
ipv6 ospf cost 781
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 10.0.0.0
no auto-summary
!
ipv6 router rip CCNA
!
ip classless
!
!
!
!
!
!
!
line con 0
password 7 0822455D0A16
logging synchronous
login
line vty 0 4
password 7 0822455D0A16
login
!
!
!
end

R2

R3#sh run
Building configuration...

Current configuration : 1104 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R3
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
ip ssh version 1
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
description ***Link to SW3***
ip address 10.3.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description ***Link to SW4***
no ip address
duplex auto
speed auto
ipv6 address 2001:3:3:3::1/64
!
interface Serial0/0/0
description ***Link to R1***
ip address 10.2.2.2 255.255.255.0
ipv6 address 2001:2:2:2::2/64
ipv6 rip CCNA enable
ipv6 ospf cost 781
clock rate 64000
!
interface Serial0/1/0
no ip address
ipv6 ospf cost 781
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
network 10.0.0.0
no auto-summary
!
ipv6 router rip CCNA
!
ip classless
!
!
!
!
!
!
!
line con 0
password 7 0822455D0A16
login
line vty 0 4
password 7 0822455D0A16
login
!
!
!
end


No comments:

Post a Comment